Sep 22 2009

Bug der Zeilennummern bei Flex Builder und Snow Leopard

Tag: Adobe,Mac OSXKonstantin Elstner @ 09:05

Nach dem ich gestern über einen Bug bei dem Canon MX850 und Snow Leopard (Mac OS 10.6.x) berichtet hatte, nun ein weiterer, den Flex Builder betreffend.

Ich war gestern beim Arbeiten an einem Projekt recht irritiert darüber, dass sich die Zeilennummern nicht aktualisierten. Sie wirkten wie eingefroren und zeigten nur den Zeilennummer-Ausschnit des initialisierten Zustandes des Fensters nach dem Start.

Nach dem ich das Problem sowohl bei Flex Builder 3 wie auch dem kommenden Flash Builder, Codename Gumbo, beobachtet hatte überlegte ich ob es ein Projekt bezogenes Problem sein könnte. Jedoch war dies leider nicht der Fall. Nach einigen googeln fand ich im Adobe Forum einen Beitrag in dem exakt das selbe Verhalten beschrieben wurde.

Unter Snow Leopard treten folgende Probleme auf, für die bisher kein Bugfix bekannt ist:

  • Starke Performanceeinbrüche bei der Aktualisierung des Workspaces CPU-Last bis 100%
  • Wird auf einem 2. Monitor mit dem Flex Builder gearbeitet, so aktualiseren sich die Zeilennummern nicht, dies funktioniert jedoch einwandfrei auf dem primären Display

Betroffen von den genannten Bugs scheinen alle Mac OS 10.6.x Systeme zu sein. Da der Flex Builder Eclipse basierend ist, vermute ich hier das Problem und kann nur empfehlen, die nächsten verfügbaren Eclipseupdates zu installieren. Die aktuell verfügbaren bringen leider keinen Bugfix.

Daher meine Empfehlung:

Besteht kein dringender Snow Leopard Bedarf, so sollte man noch abwarten bis alle Bugs behoben sind und dann sicher upgraden, die Vorteile hingegen den aktuellen Problemen sind minimal.


Sep 21 2009

Mac OS 10.6.x und der Canon MX850 [fixed]

Tag: Mac OSXKonstantin Elstner @ 09:08

Nach dem Update von Mac OS auf Snow Leopard (10.6) am Wochenende musste ich leider feststellen, dass mein Drucker, der Canon MX850, nicht mehr installiert war.

Per USB ließ er sich  ohne Probleme sofort mit den aktuellen Treibern von www.canon.de installieren. Auch per Netzwerk fällt jetzt positiv auf, dass der Scannertreiber nun nativ für das System zur Verfügung steht.

Jedoch die Installation des MX850 per Netzwerk wollte nicht so recht. Nach einigen googeln stellte ich fest, dass ich nicht der Einzige bin den es getroffen hat.

Es gibt zwar eine kursierende Beschreibung wie es nach dem Aufruf des Netzwerktools klappen sollte, jedoch können andere User und auch ich dies nicht bestätigen.

Bei einem eben geführten Telefonat mit dem Canon Support (am 21.9.09), habe ich die Information erhalten, dass die Installation unter 10.6 aktuell nicht möglich ist! Da das Netzwerkdruckertool noch nicht portiert wurde. Den internen Zeitplänen von Canon nach zu Folge, sollte das Tool jedoch ab Freitag zur Verfügung stehen, da man alle Software bis 4 Wochen nach dem Snow Leopard Release portieren wolle.

Daher bleibt also nur abwarten und hoffen, dass keine all zu großen Portierungsprobleme auftreten.

UPDATE:

Einfach der Anleitung von Alexander in den Kommentaren folgen.

Kurzfassung:

  • Druckertreiber von Canon.de neuinstallieren – die CUPS Version
  • Dann das Networktool neuinstallieren
  • Dann wie von der Installation gefordert neustarten
  • Und nach dem Neustart in die Druckereinstellungen wechseln
  • Kurz warten, per + einen neuen Drucker hinzufügen
  • Nach ca. 10 Sekunden erschien nun auch der Drucker in der Liste
  • Installieren und alles läuft wie früher 😉

WICHTIG: Diese Lösung scheint nur kurz nach dem Neustart zu gehen, daher sollte man nicht zu lange warten!

Riesen Dank an Alex